Backup everything. First rename, then remove when you confirmed it worked. Better safe than sorry.

REM Set the new root location
REM Ex. NEW_ROOT=D:
REM     NEW_ROOT=D:\Data
REM     NEW_ROOT=D:\MyStuff\MyComputer
set NEW_ROOT=D:

REM (Make sure that C:\Users doesn't exist anymore)
move C:\Users C:\Users.Backup
mklink /J C:\Users %NEW_ROOT%\Users

REM DO NOT DO THE FOLLOWING
REM (Rename C:\ProgramData before creating the link)
move C:\ProgramData C:\ProgramData.Backup
mklink /J C:\ProgramData %NEW_ROOT%\ProgramData

REM Update the TEMP folder at system level
setx /m TEMP %NEW_ROOT%\Windows\Temp
setx /m TMP %NEW_ROOT%\Windows\Temp

move C:\Windows\Temp C:\Windows\Temp.Backup
mklink /J C:\Windows\Temp %NEW_ROOT%\Windows\Temp
REM END DO NOT DO
26 Apr 2009

Software developer

joke

A man is flying in a hot air balloon and realizes he is lost. He reduces height and spots a man down below. He lowers the balloon further and shouts: "Excuse me, can you tell me where I am?"

The man below says: "Yes you're in a hot air balloon, hovering 30 feet above this field."

"You must be a software developer," says the balloonist.

"I am," replies the man. "How did you know?"

"Well," says the balloonist, "everything you have told me is technically correct, but it's of no use to anyone."

The man below says, "You must work in business as a manager." "I do," replies the balloonist, "but how did you know?"

"Well," says the man, "you don't know where you are or where you are going, but you expect me to be able to help. You're in the same position you were before we met but now it's my fault."

Source: Coding Horror

Since I've upgraded to Leopard, I couldn't connect to my Windows network anymore. Browsing through various websites looking for answers, I tried pretty much all of them with no success. Not until I found this page. Is explanation is pretty simple and indeed makes my shared network show up once again!

Here's the explanation and instructions on how to fix it:

You have plenty of suggestions for fixing the Leopard Windows sharing issue, that I see are all a bit hit or miss. I think the reason for this is because a lot of the things people are trying are fixing the real root issue by accident.

The Leopard advanced network settings has a WINS tab, and in this there is a NETBIOS name field. This is auto-generated by Leopard - it looks like it uses the MAC address to generate it. However, if what is put in there is not compliant with the NETBIOS settings of the Windows network you are connected to, then browsing will not work, because the WINS server will not acknowledge the WINS requests coming from Leopard.

The actual NETBIOS name requirements supported vary depending on the flavour of OS running on the WINS servers on the network. I would suspect the best route to success is to use the most basic NETBIOS name requirements, back from the old Windows NT 4.0 days - stick in no more than an 8-character alphanumeric into the NETBIOS field, and all Windows browsing will be restored.

I had two Leopard machines, one which would browse and one which would not. The browsing one had an 8-character WINS setting, and the non- browsing one had a MAC address in the WINS field. Removing the MAC address and putting in a simple word in the WINS field IMMEDIATELY reinstated browsing.

If you're having a hard time getting Boot Camp to correctly install Windows and you're getting either a "disk error" or "hal.dll missing" error, here's how to actually fix it.

First, you'll have to restore your disk to a full Mac OS X partition.
Then, you'll reformat it to be a Mac OS X partition and a Windows partition (using Boot Camp).

This is now the important step. You must write over the partition. So load up the Terminal and enter

sudo dd if=/dev/zero of=/dev/rdisk0s3 bs=1m count=100

Where rdisk0s3 is the disk where the Windows Partition is. To know the name of your Windows partition, you can go to the Disk Utility (Applications-Utilies) and look for a partition under your hard drive.

When that is done, you can restart your computer with your Windows CD and install it. Everything should be fine now.

PS. Use at your own risk. The command involve writting 0's to your partition table, which might screw it up if done unproperly.

PPS. I cannot be held responsible for anything happening to you or your computer.

If you're having trouble with your DVD not being detected in Windows XP while being detected in the BIOS, this is THE solution you've been looking for.

This problem is generally caused by the Adaptec ASPI drivers needing to be updated. The best way to fix this problem is to download the latest Adaptec aspi_471a2 drivers. You can download them at Softpedia.com.

Good luck!